Color Management for Designers and Photographers

It's just a matter of picking the right options in Photoshop CS3

Color...management—may be two of the most frightening words uttered in all of digital imaging. But color management isn't inherently more difficult to understand than image resolution or calculations. First, understanding some fundamental concepts is essential; then it's just a matter of choosing the correct options within Adobe Photoshop CS3, based on your ultimate image-processing goals. So, we'll start with color theory. Don't worry! I promise this will be equation free.
Why do we need color management?
Our computers only understand the language of numbers: series of 1's and 0's. It doesn't matter if you're viewing a webpage, spreadsheet, or a full-color image in Photoshop, your computer simply operates on sets of these values.

Numbers alone don't provide enough information to describe how a color should appear, however. (You might get a speeding ticket if I tell you the speed limit is 95 and don't tell you whether it's miles or kilometers per hour.) Not only do we need color numbers, we also need the scale of the numbers. For example, R:198, G:78, B:90 has a higher red value than green or blue. You might guess it's a reddish color, but how red? Worse, the same set of color numbers often produces a different color appearance on any two dissimilar devices.

It's number management, that's all
Using Photoshop's Color Picker, you can define the most saturated green by typing in R:0, G:255, B:0. Photoshop associates these values to something called a "color space," which provides a scale for these numbers, based on human vision.

The horseshoe-shaped illustration is a two-dimensional plot of all the colors that humans can see based on the visible spectrum (remember Isaac Newton?). It's the color space of human vision and within that scale, we can plot all other color spaces.

We plotted two color spaces: sRGB and Adobe RGB (1998). Notice that the most saturated green of both color spaces falls onto two different locations. The same set of numbers—R:0, G:255, B:0—produces two different colors of green. Photoshop can only display these colors correctly once it knows the numbers and the scale: the color space!

As plotted, Adobe RGB (1998) holds more volume than sRGB. The size of the color space is called its "color gamut" and the entire horseshoe-shaped plot represents the gamut of human vision. Some wavelengths of light energy fall outside this plot and we can't see them, because they're invisible. And there are colors in Adobe RGB (1998) that fall outside the color space of sRGB: These colors are out of gamut. A color space defines the numbers, scale, and gamut of all the devices that we'll work with—input devices, displays, and output devices—and all of these devices produce colors differently. They have a different-shaped and -sized color gamut, primarily because of their differences in colorants, such as inks, toners, silver media, the fluorescent light inside your LCD, or anything used to reproduce color.

Each printer requires a different set of RGB or CMYK values (color spaces) to produce the same color. To keep track of these unique color spaces for our devices, we use ICC device profiles, which define the color space of all the capture and output devices we hope to color-manage by defining the numbers. The key to color management (really number management) is to use ICC profiles for all devices and documents used within Photoshop.

Correct color previews
For Photoshop to provide correct color previews of all documents, it needs access to two ICC profiles, the first of which defines how our display behaves. The other profile defines the color space of all the documents we'll work with. (Note: It's critical to have a hardware solution that can regularly calibrate and profile your display.)

For instance, when an image is defined as sRGB or Adobe RGB (1998), Photoshop understands the scale of the color numbers of that document and then uses the display profile to preview these numbers correctly. When Photoshop encounters a document that doesn't have an embedded ICC profile, it's forced to guess the color space of these numbers, which can result in incorrect color previews: You may view an image that appears too dark or has a color cast. If Photoshop is to work correctly, you should have a calibrated and profiled display and also ensure that all your documents have an embedded ICC profile defining the color numbers properly.
Color management in Photoshop CS3

There are five key areas in Photoshop to control color management from input to print: Color Settings, Assign Profile, Convert to Profile, Customize Proof Condition, and Print. Entire chapters in books have been written to describe these dialogs but, given the space constraints, I'll try to give you an overview of what each does.

Color Settings

The most complex dialog we'll examine is Color Settings (Edit>Color Settings or press Shift-Command-K [PC: Shift-Ctrl-K]). The top three sections of the dialog—Settings, Working Spaces, and Color Management Policies—are the most important to understand and configure.

Settings provides a pop-up menu with presets that control all the other items in this dialog. (Note: You can create your own presets as well.) Initially, most users set it to North America Presets v2. These are safe default settings. Once you have a better concept of how the color settings work, you can alter them and save your own preset.

The Working Spaces pop-up menus are available for different color models—RGB, CMYK, Grayscale, and Spot—and provide the same functionality: to tell Photoshop which working (editing) space you prefer.

In our example, RGB is set to Adobe RGB (1998), so we're telling Photoshop that this is the RGB color space we prefer to use. This doesn't limit us to working with other color spaces; it's only a preference. For CMYK, our setting indicates we prefer to use a U.S. Web Coated (SWOP) v2 profile for our CMYK work. Photoshop now "knows" that these are the document color spaces we'll use most often but more importantly, if Photoshop opens a document that has no embedded profile, it will use this color space for the scale of the numbers in these untagged images. Photoshop always has to know or assume a color space for the numbers in all documents.

If someone provides you with an RGB document with no embedded profile, Photoshop will assume that the color space is Adobe RGB (1998) and preview those numbers as if they were in that color space. The document may not be in this color space, and as you'll see below, we can handle that using the Assign Profile command.

For more information on Working Spaces, see "The Role of Working Spaces in Adobe Applications" at www.adobe.com/digitalimag/pdfs/pscs2isp_colspace.pdf.

In the Color Management Policies section, it's a good idea to keep your color policies set to Preserve Embedded Profiles to ensure that when opening a document, you'll maintain its original color space. If the document's color space matches the color space selected in your color settings, the document just opens; but if it doesn't match, an Embedded Profile Mismatch warning dialog pops up. Just click OK to allow this document to open in its original color space, previewing as originally intended. Our example shows that we're trying to open a file in ColorMatch RGB and our preferred working space is Adobe RGB (1998). Because of the Preserve Embedded Profiles color management policy, Photoshop will open and preview the document as originally intended—in ColorMatch RGB.
At the bottom of this section, check all the Profile Mismatches boxes (until you’re totally comfortable with the color settings). Photoshop will now inform you when you’re opening documents without an embedded profile, or documents that don’t match your preferred RGB, CMYK, and Grayscale working spaces, and even if you attempt to paste pixels into documents of dissimilar color spaces.

The other Color settings only play a role if you use the Image>Mode commands (for example, RGB to CMYK). I recommend that you do this using the Convert to Profile command (discussed later), so you need not be concerned with these presets.

Advanced Controls can also be ignored—only an advanced color geek should alter these, in rare cases.

There you have a short-and-sweet explanation of the Color Settings dialog. [Courtesy of Andrew Rodney, NAPP members may download a PDF of a step-by-step tutorial on the warnings and policies from www.photoshopper.com/members/magcenter/2007.php.]

Assign Profile
Documents that don’t have an embedded ICC profile consist of numbers with an unknown color space. Untagged documents are problematic because Photoshop is guessing about the color space based on the Working Space settings—is this the correct color space?

Here’s when you use the Assign Profile command (Edit>Assign Profile), selecting different profiles to see which one produces the desired color appearance. Photoshop will use the display profile and the currently assigned profile to update the preview based on how these two profiles interact, illustrating how assigning different profiles changes the color appearance but not the actual color numbers. You can verify this by viewing the Info panel. Notice the effect of assigning profiles: the numbers remain the same while the color appearance can radically change.

Assigning different profiles doesn’t change the current RGB or CMYK values; it provides a new definition or scale of the existing numbers. The result is a different color appearance.

Section A shows the correct color appearance, as the document is ColorMatch RGB.
In B and C, Photoshop incorrectly previews the numbers as ProPhoto RGB and sRGB.
Convert to Profile

Convert to Profile is often confused with the Assign Profile command. Assigning a profile tags or embeds a profile into a document but doesn’t change the color numbers. Convert to Profile does change the color numbers by converting them into the color space selected in the Destination pop-up menu. The profile used for conversion is embedded into the document.

For instance, to convert from Adobe RGB (1998) to sRGB, select sRGB. To prepare an image for printing on a press that conforms to SWOP standards, pick the U.S. Web Coated (SWOP) v2 profile. Next select a rendering Intent, which controls the mapping of out-of-gamut colors. Select one that produces the color appearance you prefer (often largely subjective): Try Relative Colorimetric, then Perceptual. Leave the other checkboxes on at all times.

You’ll see what’s called a soft proof—an onscreen simulation of the color and tone, based on the final output device as described by its ICC profile. When Photoshop is told about the print or output condition using an ICC profile, it can produce this onscreen simulation.

Customize Proof Condition

The Customize Proof Condition dialog, like Convert to Profile, provides you with a soft proof based on the currently loaded ICC profile, allowing you to edit your images while viewing the soft proof. Images will soft proof based on what’s selected in this dialog. The two Simulate checkboxes further update the soft proof by taking the dynamic range of the paper and ink into account and altering this relationship visually onscreen.

(Note: You can toggle your soft proof on and off using the Command-Y (PC: Ctrl-Y) key.)

While providing a more accurate soft proof, it can look particularly ugly as the preview updates, and it’s usually only effective when you view an image in full-screen mode without any menus or palettes showing. (Press the F key until you get into full-screen mode, and then press the Tab key to hide all the panels.) Now compare this soft proof to the printed output under a controlled light box.

For this image, I need four presets (one for each printer to whom I want to send soft proofs): Perceptual, Relative Colorimetric, one with, and one without the Simulate checkboxes. You can configure and save soft-proof presets by choosing View>Proof Setup>Custom.

Tip: Save these soft proof presets to disk to share with other users (the ICC profiles are embedded in the PSF documents).
Print

Print (Print with Preview in CS/CS2) provides the functionality of Convert to Profile in a dialog that applies color management to an open document when sending it to a local printer. The conversion options are the same: choose an output (Printer) Profile and Rendering Intent. New in CS3, however, is a soft proof in the Preview window and the Simulate paper and ink options are locked on by default.

After clicking Print, a dialog appears where you'll configure your printer driver before you print your image. Tip: I use the Print dialog when printing in-house and the Convert to Profile feature when I need to create a copy in an output color space to supply to others.

The key to getting predictable screen-to-print matching is having a calibrated and profiled display and all the ICC output profiles for the devices you wish to properly view and edit. If you set up Photoshop correctly, it will produce very good onscreen simulations of your digital numbers because you have color-managed these numbers.